安装PrestaShop 报错 :Install and/or enable a PHP accelerator (highly recommended).

本文由清尘发表于2019-04-01 12:52最后修改于2019-04-25属于技术文档分类

1.Install and/or enable a PHP accelerator (highly recommended).

意思是:安装或使用一个PHP加速器(强烈建议)

其实在php5.5已经集成Zend Opcache功能,以前一般用APC,但是在PHP5.5以后都用Opcache代替,缓存速度比APC更快。Zend Opcache的扩展dll文件在php扩展目录ext下,文件名php_opcache.dll。

在php.ini文件里配置即可使用

打开php.ini文件,里面加入(zend_extension里面的路径会有不同)

; 使用zend_extension指令来将OPcache扩展加载到PHP中
; php_opcache.dll文件的实际路径
zend_extension=D:\php\ext\php_opcache.dll
; 使用下列推荐设置来获得较好的性能
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1

2.Install and enable the intl extension (used for validators).

php.ini中开启intl支持

然后重启apache服务器